nix-cfg/hosts/laptop/mounts.nix

33 lines
715 B
Nix

{
systemd.mounts = [
{
where = "/mounts/my_data";
what = "/dev/disk/by-label/My_Data";
type = "ntfs3";
options = "defaults,exec,noauto,prealloc,uid=1000,gid=100";
}
{
where = "/mounts/windows";
what = "/dev/disk/by-label/WinPart";
type = "ntfs3";
options = "defaults,exec,noauto,prealloc,uid=1000,gid=100";
}
];
systemd.automounts = [
{
where = "/mounts/my_data";
wantedBy = ["multi-user.target"];
automountConfig = {
TimeoutIdleSec = 901;
};
}
{
where = "/mounts/windows";
wantedBy = ["multi-user.target"];
automountConfig = {
TimeoutIdleSec = 901;
};
}
];
}