mirror of
https://git.lgmrszd.xyz/Lgmrszd/nix-cfg.git
synced 2024-12-22 16:09:50 +01:00
15 lines
444 B
Nix
15 lines
444 B
Nix
{ config, data, pkgs, ...}:
|
|
{
|
|
services.factorio = {
|
|
enable = true;
|
|
package = (pkgs.factorio-headless.override { versionsJson = ./factorio-versions.json; });
|
|
public = false;
|
|
game-name = "Lgm's Factorio Game";
|
|
openFirewall = true;
|
|
autosave-interval = 5;
|
|
extraSettings = {
|
|
autosave_slots = 8;
|
|
};
|
|
extraSettingsFile = "/var/lib/${config.services.factorio.stateDirName}/server-settings-extra.json";
|
|
};
|
|
}
|